NAS App Center

0789



KODI

Release note:
1.Upgrade KODI to version 13.2 Gotham
2.Fixed problems with YouTube video player

Note:
This module requires firmware v2.04.06 or above.
To download, follow this link: http://www.thecus.com/sp_download.php

N2800, N4510U, N4510U PRO, N4800, N4800Eco, N5550, N7510,